What You’ll Learn

Welcome! This guide features step-by-step instructions outlining the basics of working with Lumen. You’ll learn how to:

  • Load, save, and create patches
  • Twist some knobs
  • Process video from your webcam
  • Record still frames and videos
  • Show Lumen’s output on an external display
  • Save patch variations to the Snapshots Pad
  • Remote-control Lumen from a MIDI Controller

To get the most from this guide, you need to at least have the free Lumen Demo downloaded and installed. If you haven’t done that yet, do that now and come back!

Lumen Interface Basics

Lumen is a semi-modular analog-style video synthesizer. This means it can process or generate video in real-time using its various submodules.

First let’s go over some of the basics of its interface - after that, we’ll make some art. Lumen has three main interface panels, named Browse, Knobs, and Patch.

To show a panel, just click the corresponding button in the Panel Switcher:

Panel Switcher Screenshot Highlight

Keyboard Shortcuts Press the Tab key to switch between the Knobs and Patch panels, and the Shift+Tab key to take you to and from the Browse Panel.

Browse Panel

Browse Panel Screenshot
We’re starting with the most basic of the three panels, the Browse Panel. This is where you load and manage your Patch Library. “Patch” is just a fancy synthesizer word for a saved setup - think of them like files on a computer. Lumen’s Patch Library comes with a bunch of built-in patches curated from some of our favorite artists, so you can start having fun and creating art without knowing anything about video synthesis. We call these built-in patches Presets.

To Load a Patch, double-click on it in the Patch Library. You can also load a patch by single-clicking it to select it, and hitting the Enter key.

XY-Pad Screenshot Highlight

You may have also noticed the XY-Pad labeled Snapshots in the bottom-right of this panel. The Snapshots pad can be used to view different variations on the patch. Click and drag on it to see!

Pro Tip Hold the Control key while dragging on the Snapshots Pad to slow down how quickly the patch snapshot changes. Hold down Control+Shift to have it change in super slow motion.

Knobs Panel

Knobs Panel Screenshot

When using Lumen, you’ll spend most of your time in the Knobs Panel, setting the synth’s parameters.

Let’s have some fun making something with it:

  1. If you haven’t done it yet, switch to the Knobs Panel by clicking “Knobs” in the panel switcher at the top-left of Lumen’s window. Panel Switcher
  2. Create a New Patch by selecting File -> New from the application menu, or by pressing Command+N. This resets all of Lumen’s parameters and disconnects any connections made on the Patch Panel - basically, it resets the whole synth to a blank slate.
  3. Let’s adjust some knobs on an oscillator. Find the knob labeled Mod on the middle oscillator and turn it up by left-clicking on it and dragging upwards. Knobs Panel Screenshot
  4. In that same oscillator, find the knob labeled Sync and turn it up too.
  5. Find the big Frequency knob above the sync knob you turned up and turn it to a setting that looks cool to you.
  6. Congratulations! You should have something that looks like crossed with displaying in Lumen’s video screen.

Keyboard Shortcuts Just like with the Snapshots Pad, holding Control while dragging on a knob will adjust it more slowly, and holding Control+Shift will adjust it really really slowly. Finally, holding just Shift while twisting a knob will snap it to certain predefined values. Now you’re a knob-twisting pro.

Pro Tip Double-click a knob to reset its value to the default. Undo (Edit -> Undo or Command+Z) and Redo (Edit -> Redo or Command+Shift+Z) also work for twisting knobs.

The Mod, Sync, and Frequency knobs are the ones you’ll use the most when putting together a patch. For more detail on how these parameters actually affect the video that is generated, check out our guide on Oscillators. ​

Patch Panel

Patch Panel Screenshot

The Patch Panel is the most complicated but also the most powerful of Lumen’s panels. It allows you to reroute the signal flow of the synth to expand Lumen’s capabilities enormously. Many of the presets that come with Lumen use the Patch Panel to get their signature looks and to change the way the Knobs Panel functions.

It is basically Lumen’s secret superpower. Don’t tell anyone.

If you feel like getting lost in its labyrinthine corridors, I would suggest that you get used to the basics of the synth by reading several other guides before diving in - like the one on Oscillators and the one about Modulation. After that, head over to the Patch Panel Intro, where your real training will begin.

Processing Video from a Webcam

Video synths like Lumen aren’t just used for generating video patterns - they can also be used to apply effects to external video. Lumen lets you process the output of most cameras that appear as a webcam in macOS, along with any apps (like VDMX or Resolume) that support Syphon output.

Let’s do this together now:

Selecting your webcam in Lumen

  1. Create a New Patch by selecting File -> New from the application menu, or by pressing Command+N. We’re doing this because having connections on the Patch Panel can complicate what we’re trying to do here.
  2. Select your webcam (usually called something like “FaceTime HD Camera”) from the Camera Input Dropdown button at the top of the screen.
  3. Switch some oscillator sources to Cam by clicking the Oscillator Source Buttons labeled “Osc” in the middle of the Oscillator row. There are three total, and in the default patch, they correspond to the Red, Green, and Blue channels of your webcam input.
  4. You’ll see that some of the oscillator controls are now disabled. That’s because in “Cam” mode, those controls don’t do anything. BUT the other oscillator controls totally do stuff still - try messing with them!

Tech Note Processing external video from a webcam makes your computer think really hard, so if you are creating a patch and don’t end up using your camera, you can disable it by selecting “None” from the Camera Input Dropdown. This will save some processing power and make Lumen run more smoothly.

Tech Note Any new Mac-compatible webcams should work with Lumen. Older webcams, however, might not have updated drivers for 64-bit macOS, in which case they will not be compatible. It’s tough to say which webcams have updated drivers and which ones don’t, so with older webcams, you’ll have to try them out before you know for sure. If you’re looking to get an external webcam, I’ve had a really fun time playing with this one - it looks good, isn’t that expensive, and is fully compatible with Lumen.

For more in-depth information about the ways that you can process external video sources in Lumen, see our External Signal Processing guide. ​

Saving Patches

When you turn on Lumen, the patch you turned it off will be restored. If you’d like to keep more than one patch at a time, however, you can save patches to the Patch Library, to load them later!

Full Version Saving patches is only available in the full version of Lumen.

Save and Duplicate Buttons

To save your current patch to the Patch Library, click the Save Button (or press Command+S or choose File -> Save from the application menu). If you’ve loaded a patch from the Patch Library, made changes to it, and save it this way, it will overwrite the original patch in the library.

What if you’ve made some changes to a patch that you like, but you don’t want to overwrite your old patch? Just press the Duplicate Button (or press Command+Shift+S or select File -> Dupicate) to save a new copy of your patch. This way, you can experiment without worrying!

Pro Tip You can get your name and information saved with a patches by choosing Lumen -> Author Profile from the application menu.

Recording Still Frames and Videos

Recording Still Frames

You can save images from your patches directly from Lumen. Just press Command+Shift+C or use the Patch -> Capture Still Frame menu item.

The image will be saved to your desktop and automatically named NNNN Lumen Frame.png, where NNNN is a number between 0001 and 9999.

Full Version In the demo version of Lumen, you’ll notice that the screen output has a watermark. Don’t worry, though - you can remove the watermark by unlocking the full version.

Recording Videos

Recording videos directly is not included in Lumen just yet. For the time being, you can record videos using the free third-party Syphon Recorder app from the Syphon project. Below, we’ll talk about how to get it all set up.

Setting up Syphon Recorder

After downloading and installing the app, open up Syphon Recorder’s preferences, either by using the Syphon Recorder -> Preferences menu item or by the Command+, keyboard shortcut. Below you’ll see the settings that are important for recording Lumen videos:

  1. Set Frame Rate to “60”
  2. Set Dimensions to “640 x 480 (NTSC)”

Syphon Recorder Preferences

Now we’re ready to record!

Recording with Syphon Recorder

Syphon Recorder Recording

  1. While Lumen is running, select “Main Output - Lumen” in the Source dropdown.
  2. When you’re ready, push the Record button, and you’re live!
  3. Once you’re done, press the Stop Recording Button.
  4. The external app Quicktime Player should open up. You can now review, edit, and save your movie. It’s worth noting that by default Syphon Recorder also saves movies in the Movies/Syphon Recordings directory under your user directory.

Full Version You might notice that recorded videos in the demo version of Lumen have a watermark. The full version is not watermarked!

Using Lumen with an External Display

Lumen allows you project your patch on an external monitor, projector, or TV. To go fullscreen, select Patch -> Fullscreen -> Device from the application menu.

Tech Note In order for your external display to be usable by Lumen, it must appear as a monitor in macOS. If you’d like to connect Lumen’s output to a device that uses analog RCA inputs, like an old CRT TV or a hardware video synth, I’d suggest using a HDMI to RCA adapter if your Mac has an HDMI output port. You can use a Thunderbolt to HDMI adapter along with the HDMI to RCA Adapter if your Mac only has a Thunderbolt port.

Saving Patch Variations to the Snapshots Pad

Snapshots Pad

We talked earlier about how you can click and drag on the Snapshots XY-Pad in order to smoothly blend between variations on a patch (called “Snapshots”). But how do you save your own snapshots to the snapshots pad? It’s actually quite simple:

  1. Switch to the Knobs panel by clicking “Knobs” in the panel switcher at the top-left of Lumen’s window.
  2. Move Lumen’s knobs to where you’d like them to be for your snapshot.
  3. Click the Save button in the corner of Snapshots pad that you’d like to store the current knob positions in.

That’s it! Now when you drag the pad to that corner, the knobs will move to the position you were in when you saved them. Note that switches, dropdowns, and patch cables aren’t saved with snapshots.

Pro Tip You can hold down the Command key while twisting a knob to save only that knob’s value to all four snapshots at once.

MIDI-Mapping Lumen’s Interface

MIDI Control Example

Controlling Lumen with a mouse and keyboard is endless fun, but sometimes it’s great to have a little hands-on control . Thankfully, Lumen supports remote-control via the MIDI protocol. This means that you can twist real actual knobs on an external MIDI controller and have them control Lumen’s interface.

To get this to work with your particular MIDI controller, you have to link the knobs and buttons in Lumen to those on your controller. The name for this link is called a Mapping. Let’s make some mappings:

  1. First, click the Remote Control Button to put Lumen in Remote Control Mapping Mode (you can also press Command+M to do the same thing): Remote Control Button
  2. A popup window called “Remote Control” will appear. In this window, use the MIDI Source Picker to select the MIDI controllers you’d like to have Lumen respond to: Remote Control Mapping Mode
  3. You’ll also see blue dotted outlines appear all over the knobs and buttons in Lumen’s interface – click to select one that you’d like to control with your MIDI controller.
  4. Twist the knob or push the button on your controller that you’d like to use to control it.
  5. Repeat steps 3 & 4 for each knob or button you’d like to remote-control.
  6. Once you’re done, click the Remote Control button again to leave Mapping Mode, and you’re all set!

Pro Tip Press the Delete key while a mapping is selected to remove it.

Congratulations!

You now know the basics of Lumen. To take your video synth skills to the next level, check out these guides:

What To Read Next